Upgrade/Downgrade Oracle Jrockit in Unix/Linux

#########Pre Checks:

check your product certification matrix to confirm if your installation type supports the desired version of the JDK.


1) For Oracle Fusion Middleware 11g, check the certifications in the following Note 431578.1 – How to Find Certification Details for Oracle Application Server 10g and Oracle Fusion Middleware 11g (Doc ID 431578.1)”.
2) For individual Oracle Weblogic Server configurations involving versions prior than 10.3.0, check the certifications here http://download.oracle.com/docs/cd/E13196_01/platform/suppconfigs/config_wls.html

#######Steps

Place the new JRockit under the directory and update the file as instructed in next step

change following in the setDomainEnv.sh as per the correct path where you placed the JRockit:

BEA_JAVA_HOME=”C:/bea/jrockit-jdk1.6.0_26-R28.1.4-4.0.1″
JAVA_VENDOR=”Oracle”
export JAVA_VENDOR
JAVA_HOME=”C:/bea/jrockit-jdk1.6.0_26-R28.1.4-4.0.1″
#######Rollback :

revert the changes and even JRockit can be downgraded
########References:

How to Upgrade the JDK Used by Oracle WebLogic Server to a Different Version [ID 1309855.1]

as per this foll. files need to be changed as per the upgrade :
* $FMW_HOME/wlserver_10.3/common/bin/commEnv.sh
* $FMW_HOME/user_projects/domains/<mydomain>/bin/setDomainEnv.sh
* $FMW_HOME/wlserver_10.3/common/nodemanager/nodemanager.properties
* $FMW_HOME/utils/bsu/bsu.sh
* $FMW_HOME/utils/quickstart/quickstart.sh
* $FMW_HOME/utils/uninstall/uninstall.sh

Leave a Reply